Comandos Cisco Router

Comandos para la Configuración de Routers y Switchs

Configuración del Hostname
 

Código:
Router#configure terminal
             Router(config)#hostname             [Nombre]
             Nombre(config)#Ctrl + z
             Nombre#

Configuración de Password

1.- Enable Password
 

Código:
Nombre#configure terminal
             Nombre(config)#enable password             [password]
             Nombre(config)#Ctrl + z
             Nombre#

2.- Enable Secret
 

Código:
Nombre#configure terminal
             Nombre(config)#enable secret              [password]
             Nombre(config)#Ctrl + z
             Nombre#

3.- Terminal

 

Código:
Nombre#configure terminal
             Nombre(config)#line vty 0 4
             Nombre(config-line)#login
             Nombre(config-line)#password              [password]
             Nombre(config-line)#Ctrl + z
             Nombre#

4.- Consola

 

Código:
Nombre#configure terminal
             Nombre(config)#line console 0
             Nombre(config-line)#login
             Nombre(config-line)#password              [password]
             Nombre(config-line)#Ctrl + z
             Nombre#

5.- Auxiliar

 

Código:
Nombre#configure terminal
             Nombre(config)#line auxiliary 0
             Nombre(config-line)#login
             Nombre(config-line)#password             [password]
             Nombre(config-line)#Ctrl + z
             Nombre#

Configuración de Mensaje del día
 

Código:
Nombre#configure terminal
             Nombre(config)#banner motd #
             Enter TEXT message. End             with the carácter ‘#’ Mensaje #
             Nombre(config)#Ctrl+z
             Nombre#

Configuración de la descripción de las Interfaces

 

Código:
ombre#configure terminal
             Nombre(config)#interface             [interface]
             Nombre(config-if)#description             [descripción]
             Nombre(config-if)#Ctrl + z
             Nombre#

Configuración del Registro de Configuración

 

Código:
Nombre#configure terminal
             Nombre(config)config-register             [registro]
             Nombre(config)#Ctrl + z
             Nombre#

Configuración de las Direcciones de las Interfaces

 

Código:
Nombre#configure terminal
             Nombre(config)#interface             [interface]
             Nombre(config-if)#ip address             [dirección] [máscara]
             Nombre#config-if)#no             shutdown
             Nombre(config-if)#Ctrl + z
             Nombre#

Configuración del Protocolo

 

Código:
Nombre#configure terminal
 Nombre(config)#router rip
 Nombre#config-router)#Ctrl.+z
 Nombre#

Configuración de Rutas Estáticas

 

Código:
Nombre#configure terminal
 Nombre(config)#ip router ip_[red_origen]  [ máscara_destino]  [ip_interface_destino]
 Nombre(config)#Ctrl.+z
 Nombre#

Configuración de redes Directamente Conectadas

 

Código:
Nombre#configure terminal
 Nombre(config)#router   [protocolo]
 Nombre(config-router)#network   [dirección]
 Nombre(config-router)#Ctrl+z
 Nombre#

Configuración de la Secuencia de Arranque

 

Código:
Nombre# configure terminal
 Nombre(config)#boot system flash gsnew-image
 Nombre(config)#boot system tftp test.exe dirección
 Nombre(config)#boot system rom
 Nombre(config)#Ctrl+z
 Nombre#

Configuración de Hosts

N

Código:
ombre#configure terminal
 Nombre(config)#ip host [nombre][direcciones]
 Nombre(config)#ctrl.+z
 Nombre#

Comandos*ACL*estándar*

Paso 1 Definir la*ACL

 

Código:
Router(config)# access-list  [access-list-number] {permit | deny}  {test-conditions}

Paso2: Aplicar la*ACL*a una interface

 

Código:
Router(config-if)# {protocol} access-group [access-list-number]

Comandos any

 

Código:
Router(config)# access-list 1 permit   0.0.0.0          255.255.255.255  
                                                       cualquier IP     máscara wildcard

Se puede usar esto:*
 

Código:
Router(config)# access-list 1 permit any

Comando host

 

Código:
Router(config)# access-list 1 permit  172.30.16.29       0.0.0.0
                                                         dirección IP      máscara wildcard
se puede usar *

Router(config)# access-list 1 permit host 172.30.16.29
Comando para ver las*ACL

Router(config)# show access-list [access-list-number]

Comandos*ACL*extendidas

 

Código:
Router(config)# access-list [access-list-number] {permit | deny} [protocol] [source-address] [source-mask] [destination-adress] [destination-mask] operator [operand] [established]  
 
Router(config-if)# {protocol} access-group [access-list-number] {in | out}

Comandos ACL nombradas

 

Código:
Router(config)#ip*access-list*{standard*|*extended}*[name]*

El Comandos deny
 

Código:
deny*{source*[source-wildcard]*|*any}

Comandos Show*
 

Código:
Router# show running-config
     Router# show startup-config
     Router# show memory
     Router# show stacks
     Router# show buffers
     Router# show arp
     Router# show processes
     Router# show nvram
     Router# show flas
     Router# show version
     Router# show processes cpu
     Router# show tech-support

Comandos Copy

 

Código:
Router# copy running-config tftp
     Router# copy tftp running-config
     Router# copy flsh tftp
     Router# copy tftp flash

Comandos de Inicio
 

Código:
Router(config)# config-register   0x2102
 Router(config)# boot system flash   igs-j-1.111-5
 Router(config)# boot system tftp   igs-j-1.111-5

Encapsulamiento PPP*
 

Código:
Router(config)# interface Serial 0
 Router(config-if)# encapsulation ppp
 Router# show interface s 0

PPP con autenticación PAP*

R

Código:
outer(config)# interface Serial 0
 Router(config-if)# encapsulation ppp
 Router(config-if)# ppp authentication pap
 Router(config-if)# ppp pap sent-username LabB password class

PPP con autenticación CHAP
 

Código:
Router(config)# interface Serial 0
 Router(config-if)# encapsulation ppp
 Router(config-if)# ppp authentication chap
 Router# username LabB password class

ISDN -Configuración del Router Gateway

Código:
Router-Gateway(config)# username  ISP pass  class
 Router-Gateway(config)# isdn switch-type bassic-dms100
 Router-Gateway(config)# dialer-list  1  protocol   ip  list  101

 

Código:
Router-Gateway(config)# access-list  101  deny  igrp any   any
 Router-Gateway(config)# access-list  101  permit  ip  any   any
 Router-Gateway(config)# ip route  172.30.0.0  255.255.0.0   bri0
 Router-Gateway(config)# interface bri0
 Router-Gateway(config-if)# ip   add  10.0.0.3  255.0.0.0
 Router-Gateway(config-if)# encapsulation  ppp
 Router-Gateway(config-if)# ppp   authen   chap
 Router-Gateway(config-if)# dialer-group   1
 Router-Gateway(config-if)# dialer map   ip   10.0.0.4   name   ISP   8315551234
 Router-Gateway(config-if)# isdn   spid1   08443   213
 Router-Gateway(config-if)# isdn   spid2   08132   344

ISDN -Configuración del Router ISP
 

Código:
Router-ISP(config)# username  Gateway pass  class
 Router-ISP(config)# isdn switch-type bassic-5ess
 Router-ISP(config)# dialer-list  1  protocol   ip  list  101
Router-ISP(config)# access-list  101  permit  ip  any   any
 Router-ISP(config)# ip route  192.168.15.0  255.255.255.0   10.0.0.3  
 Router-ISP(config)# interface bri 0
 Router-ISP(config-if)# ip   add  10.0.0.4  255.0.0.0
 Router-ISP(config-if)# encapsulation  ppp
 Router-ISP(config-if)# ppp   authen   chap
 Router-ISP(config-if)# dialer-group   1
 Router-ISP(config-if)# dialer map   ip   10.0.0.3   name   Gateway   4085559988

Comandos Opcionales ISDN
 

Código:
Router-ISP(config-if)# dial wait-for-carrier  time  seconds
Cantidad de segundos que la interface espera a la portadora cuando se realiza un pedido. El vlor por default es de 30 segundos

 

Código:
Router-ISP(config-if)# dialer idle timeout  seconds
Especifica la cantidad de segundos de inactividad que se deben esperar antes de desconectar una llamada. El valor por default es de 120 segundos

 

Código:
Router-ISP(config-if)# dialer load threshhold   load   [outbound   |  inboud   |  either]
Configura el*ancho de banda*a pedido estableciendo la carga máxima antes de que el dispositivo de discado realice otra llamada hacia un destino. La carga equivale a la carga de interface de 1 a 255, donde 255 corresponde al 100 % del*ancho de banda*disponible.

Monitoreo y Prueba de ISDN

Código:
Router-ISP# show*dialer
Muestra el estado actual del enlace
Router-ISP# show isdn active
Muestra el estado de llamada mientras se está efectuando la misma
Router-ISP# show isdn status
Muestra el estado si hay una conexión ISDN
Router-ISP# show*dialermap
Muestra las sentencias de*dialer*map ip
Router-ISP# debug q921
Muestra el establecimiento de la conexión de llamada y su desconexión
Router-ISP# debug*dialer
Muestra la configuración y la operación del dispositivo de marcación

Comandos Para Frame Relay
Router-1

Código:
Router-1(config)# interface  s 1
 Router-1(config-if)# ip add 10.16.0.1  255.255.255.0
 Router-1(config-if)# encapsulation  frame-relay
 Router-1(config-if)# bandwidth 56
 Router-1(config-if)# frame-relay  map   ip  10.16.0.2   110  broadcast  ietf
 Router-1(config-if)# frame-relay   lmi-type  ansi           (Se necesita para versiones anteriores a 11.0  
                                                                           IOS 11.0 soporta sensor LMI automático)
 Router-1(config)# router   rip
 Router-1(config-router)#  network  10.0.0.0

Router-2

Código:
Router-2(config)# interface  s 1
 Router-2(config-if)# ip add 10.16.0.2  255.255.255.0
 Router-2(config-if)# encapsulation  frame-relay
 Router-2(config-if)# bandwidth 56
 Router-1(config-if)# frame-relay  map   ip  10.16.0.1   110  broadcast  ietf
 Router-1(config-if)# frame-relay   lmi-type  ansi           (Se necesita para versiones anteriores a 11.0  
                                                                           IOS 11.0 soporta sensor LMI automático)
 Router-1(config)# router   rip
 Router-1(config-router)#  network  10.0.0.0
Ejemplo de configuración de subinterfaces multipunto

R

Código:
outer-1(config)# interface  s2
 Router-1(config-if)# no ip address
 Router-1(config-if)# encapsulation  frame-relay
 Router-1(config-if)# exit
 Router-1(config)# interface   s2.2    multipoint
 Router-1(config-if)# ip add  10.17.0.1   255.255.255.0 
 Router-1(config-if)# bandwhidth  64
 Router-1(config-if)#  frame-relay  map  ip  10.17.0.2  broadcast  ietf
 Router-1(config-if)#  frame-relay  map  ip  10.17.0.3  broadcast  ietf
 Router-1(config-if)#  frame-relay  map  ip  10.17.0.4  broadcast  ietf

 

Código:
Router-1(config)#  router  rip
 Router-1(config-if)#  network   10.0.0.0

Ejemplo de configuración de subinterfaces punto a punto
 

Código:
Router-1(config)# interface  s2
 Router-1(config-if)# no ip address
 Router-1(config-if)# encapsulation  frame-relay
 Router-1(config-if)# exit
 Router-1(config)# interface   s2.2   point-to-point
 Router-1(config-if)# ip add  10.17.0.2   255.255.255.0 
 Router-1(config-if)# bandwhidth  64
 Router-1(config-if)#  frame-relay  interface-dlci  200  broadcast  cisco
 Router-1(config-if)#  exit
 Router-1(config)# interface   s2.3   point-to-point
 Router-1(config-if)# ip add  10.18.0.3   255.255.255.0 
 Router-1(config-if)# bandwhidth  64
 Router-1(config-if)#  frame-relay  interface-dlci  300  broadcast  cisco
 Router-1(config-if)#  exit
 Router-1(config)# interface   s2.4   point-to-point
 Router-1(config-if)# ip add  10.20.0.3   255.255.255.0 
 Router-1(config-if)# bandwhidth  64
 Router-1(config-if)#  frame-relay  interface-dlci  400  broadcast  cisco
Router-1(config)#  router  rip
 Router-1(config-if)#  network   10.0.0.0

Monitoreo de Frame-Relay

Código:
Router# show frame-relay pvc
Muestra estadísticas acerca de los PVC para las interfaces Frame Relay
Router# show frame-relay map
Muestra la entrada de asignación Frame Relay actuales e información acerca de estas conexiones
Router# show frame-relay lmi
Muestra estadísticas acerca de la interface de administración local (LMI)
Router# debug frame-relay events
Muestra los sucesos de paquetes Frame Relay
Router# debug frame-relay lmi
Muestra los intercambios LMI de Frame Relay con el proveedor de servicio
Router# debug frame-relay packet
Muestra los paquetes Frame Relay
Router# debug frame-relay nli

Muestra la interface de capa de red Frame Relay
Comandos de configuración de VLAN
Los comandos son similares a los de Cisco IOS

Switch 1900 - Borrar*Archivo*de Configuración
 

Código:
1900-A#delete NVRAM
1900-A#delete vtp (hay que marcar los dos)
1900-A#show ip (muestra la IP de administración. Es una sola. ¡OJO! la IP y la VLAN en*
la misma red)

Switch Catalyst 1900 - Crear VLAN
 

Código:
1900-A#config t
1900-A(config)# vlan [vlan-number (1-999)] name [vlan-name]

Para trunk 100000 (SAID) + Número de VLAN*
 

Código:
1900-A(config)# interface fastethernet 0/4 a 27        (trunk on)  
 1900-A(config-if)# vlan-membership  [static] [vlan-number]
 1900-A(config)# show vlan
                                        vlan [vlan-number]
                                        vlan  membership

Switch Catalyst 2950 - Borrar*Archivo*de Configuración
 

Código:
2950-A# erase startup-config
 2950-A# vlan database
 2950-A# no vlan [vlan-number]      se debe borrar una por una
 2950-A(config)# interface [vlan-number]
 2950-A(config-if)# ip address [IP-address] [IP-mask]         Una IP por cada VLAN Management
 2950-A(config-if)# ip default-gateway [IP-address]

Switch Catalyst 2950 - Crear VLAN

Código:
2950-A# vlan database
 2950-A(vlan)# vlan [vlan-number] name [vlan-name]
 2950-A(vlan)# exit

Switch Catalyst 2950 -*Asignar*puertos

Código:
2950-A# interface fastethernet 0/4
 2950-A(config-if)# switchport mode [access |   trunk]
 2950-A(config-if)# switchport access vlan [vlan-number]  
 2950-A(config-if)# switchport alloed-vlan  [desde-hasta]  
 2950-A(vlan)# CTRL + Z

Switch Catalyst 2950 - Para ver VLAN

Código:
2950-A# show vlan   [all  |  vlan-number]
 

Tags: 

Predefined Sections

Seccion Cisco   Seccion Linux   Seccion Microsoft   Seccion Redes   Seccion Seguridad   Seccion General